ATTENTION: The Boards will be closed permanently on May 28th, 2014. Posting will be disabled on April 28th, 2014. More Info

Trouble with ZEN

TrickyRick25

GROUP: Members

POSTS: 1

Report this Oct. 02 2013, 7:17 am

I added 1000 ZEN to my account it confirmed it was there and now it's gone. No purchases have been made. I tried to contact tech support but their website won't let me select my product so it won't let me continue. Any advise?

Tissuepaper

GROUP: Members

POSTS: 2

Report this Oct. 02 2013, 8:52 am



You think that is bad, I just added $320 to my account last night the first of October.  Now it is the next morning and all I have received in over twelve hours in 160 dollars from them.  What kind of companies do you guy have representing you?  And, the even worse part, this is the third time they have done this.  Oh ya I get my money, after complaining they give it to me three days later.

FleetAdmiral_BamBam

GROUP: Members

POSTS: 46309

Report this Oct. 02 2013, 9:35 am

Yea... PWE's customer service is so bad, it's the determining factor for me... At this point, I absolutely refuse to give them any money.


 


But since their website is down so often, you can try e-mailing them at customerservice@perfectworld.com.

Billsy101

GROUP: Members

POSTS: 29

Report this Oct. 15 2013, 4:28 pm

Pfft I would highly doubt they answer them and if they do the emails would have been processed through a keyword/priority filter and ZEN trouble will not be high priority so add good keywords to make high priority for them will hopefully be answered quicker.


Dominating the Star Trek Universe from little, old (young) New Zealand

Recently logged in

Users browsing this forum: miklamar

Forum Permissions

You cannot post new topics in this forum

You cannot reply to topics in this forum

You cannot delete posts in this forum